News for package symfony

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 3.0 (quilt)
Source: symfony
Binary: php-symfony-asset, php-symfony-browser-kit, php-symfony-class-loader, php-symfony-config, php-symfony-console, php-symfony-css-selector, php-symfony-debug, php-symfony-dependency-injection, php-symfony-dom-crawler, php-symfony-event-dispatcher, php-symfony-expression-language, php-symfony-filesystem, php-symfony-finder, php-symfony-form, php-symfony-http-foundation, php-symfony-http-kernel, php-symfony-intl, php-symfony-locale, php-symfony-options-resolver, php-symfony-process, php-symfony-property-access, php-symfony-routing, php-symfony-security, php-symfony-serializer, php-symfony-stopwatch, php-symfony-templating, php-symfony-translation, php-symfony-validator, php-symfony-var-dumper, php-symfony-yaml, php-symfony-doctrine-bridge, php-symfony-monolog-bridge, php-symfony-phpunit-bridge, php-symfony-proxy-manager-bridge, php-symfony-swiftmailer-bridge, php-symfony-twig-bridge, php-symfony-debug-bundle, php-symfony-framework-bundle, php-symfony-security-bundle,
 php-symfony-twig-bundle, php-symfony-web-profiler-bundle,
 php5-symfony-debug
Architecture: any all
Version: 2.7.5+dfsg-1
Maintainer: Debian PHP PEAR Maintainers <pkg-php-pear@lists.alioth.debian.org>
Uploaders: Daniel Beyer <dabe@deb.ymc.ch>, David Prévot <taffit@debian.org>
Homepage: https://symfony.com/
Standards-Version: 3.9.6
Vcs-Browser: http://anonscm.debian.org/gitweb/?p=pkg-php/symfony.git
Vcs-Git: git://anonscm.debian.org/pkg-php/symfony.git
Testsuite: autopkgtest
Build-Depends: debhelper (>= 9), dh-php5, php5-dev, pkg-php-tools (>= 1.14~)
Build-Depends-Indep: dctrl-tools, file, jq, parallel, php-doctrine-bundle (>= 1.4.0-2~), php-doctrine-data-fixtures (>= 1.1.1-2~), php-doctrine-orm (>= 2.4.7-2~), php-email-validator (>= 1.2.8), php-monolog (>= 1.13), php-proxy-manager (>= 1.0.0-2~), php-psr-log (>= 1.0.0-2~), php-twig (>= 1.18), php5-common, php5-intl, php5-memcache, php5-memcached, php5-sqlite, phpab, phpunit (>= 4.2.6-3~)
Build-Conflicts: php5-mongo
Package-List:
 php-symfony-asset deb php optional arch=all
 php-symfony-browser-kit deb php optional arch=all
 php-symfony-class-loader deb php optional arch=all
 php-symfony-config deb php optional arch=all
 php-symfony-console deb php optional arch=all
 php-symfony-css-selector deb php optional arch=all
 php-symfony-debug deb php optional arch=all
 php-symfony-debug-bundle deb php optional arch=all
 php-symfony-dependency-injection deb php optional arch=all
 php-symfony-doctrine-bridge deb php optional arch=all
 php-symfony-dom-crawler deb php optional arch=all
 php-symfony-event-dispatcher deb php optional arch=all
 php-symfony-expression-language deb php optional arch=all
 php-symfony-filesystem deb php optional arch=all
 php-symfony-finder deb php optional arch=all
 php-symfony-form deb php optional arch=all
 php-symfony-framework-bundle deb php optional arch=all
 php-symfony-http-foundation deb php optional arch=all
 php-symfony-http-kernel deb php optional arch=all
 php-symfony-intl deb php optional arch=all
 php-symfony-locale deb oldlibs optional arch=all
 php-symfony-monolog-bridge deb php optional arch=all
 php-symfony-options-resolver deb php optional arch=all
 php-symfony-phpunit-bridge deb php optional arch=all
 php-symfony-process deb php optional arch=all
 php-symfony-property-access deb php optional arch=all
 php-symfony-proxy-manager-bridge deb php optional arch=all
 php-symfony-routing deb php optional arch=all
 php-symfony-security deb php optional arch=all
 php-symfony-security-bundle deb php optional arch=all
 php-symfony-serializer deb php optional arch=all
 php-symfony-stopwatch deb php optional arch=all
 php-symfony-swiftmailer-bridge deb php optional arch=all
 php-symfony-templating deb php optional arch=all
 php-symfony-translation deb php optional arch=all
 php-symfony-twig-bridge deb php optional arch=all
 php-symfony-twig-bundle deb php optional arch=all
 php-symfony-validator deb php optional arch=all
 php-symfony-var-dumper deb php optional arch=all
 php-symfony-web-profiler-bundle deb php optional arch=all
 php-symfony-yaml deb php optional arch=all
 php5-symfony-debug deb php optional arch=any
Checksums-Sha1:
 aaa8b6c31caba31183a0def92d94e20efbf559cc 3803322 symfony_2.7.5+dfsg.orig.tar.gz
 717f9855fb0ec6bfbd1857a4092dcfd7175cd6f9 37232 symfony_2.7.5+dfsg-1.debian.tar.xz
Checksums-Sha256:
 e95ebb0ff41b193f3720c2a1e675f2a4876966428685241c4dd0cec33c2cf844 3803322 symfony_2.7.5+dfsg.orig.tar.gz
 2168a1410a3e4811f2a2198cb264b9e4652030b57156b1e58a000dff7c487ff8 37232 symfony_2.7.5+dfsg-1.debian.tar.xz
Files:
 27ead73bf7537cdb8a2926f3289a1dcb 3803322 symfony_2.7.5+dfsg.orig.tar.gz
 519f8a40f137182c49e9c7e622947035 37232 symfony_2.7.5+dfsg-1.debian.tar.xz

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQEcBAEBCAAGBQJWD0XHAAoJEAWMHPlE9r08CyoH/Rgo6R7Ah2sCJtbzLhJ0+0ZZ
94APhBMeed8Vhyze5Z3V8qrsxSvzsiEGI003w0ogfOFVP6JEu6lNuQIcODqwTGyc
uMuP8lvayLm03UlvpNZqIGsE1SIKC/0/89QcFm/qlin3yBhRORWFnjS1uL8EpKbz
65S1aMGlQy5QZDE73V7dMPxqjEbxIoAqqRUunOlWTUfteBI3UN+QEh8PQUuvy+v3
vHOoh3Ec4rsdZWzfQ6wD3Qcz53IfnSVzFrV3qb5qux9lohE7XWO3FBky/sxMrUSz
bYIrUHgaeAzz4uOuDRhjljK2nUMym0mZKb45BssZx9LDGyUEQQIKefusgiB9anw=
=N30m
-----END PGP SIGNATURE-----

Changes:
symfony (2.7.5+dfsg-1) unstable; urgency=medium

  [ Fabien Potencier ]
  * updated VERSION for 2.7.5

  [ David Prévot ]
  * debian/control:
    - Drop now useless transitional dummy packages
      (php-symfony-classloader and php-symfony-eventdispatcher)
    - php5-mongo makes the tests fail, since it requires a set up
      MongoDB server
  * debian/test/control: Add missing php-doctrine-data-fixtures
    dependency for CI

  [ Daniel Beyer ]
  * Correct incomplete autoloading for php-symfony-asset
  * Run tests parallel during build time, similar to how upstream does it
  * Run DEP-8 (as-installed) tests parallel, similar to how upstream does it
  * Remove prefixed 'NNNN-'-numbering for Debian patches
  * Use a simplistic vendor/autoload.php to run tests during build time.
    This is to make sure we use the autoload.php files generated by phpab
    and additionally eliminates the need to generate a vendor/autoload.php
    using phpab during build time. Instead we use now use a symbolic link
    for vendor/autoload.php pointing to debian/autoload.build.php.
  * Include tests in autoload.php files generated by phpab
  * Use a simplistic vendor/autoload.php for DEP-8 (as-installed) tests.
    This ensures we use the autoload.php files generated by phpab during
    DEP-8 (as-installed) test. Additionally we no longer need to generate
    a vendor/autoload.php using phpab. Instead we now simply use a symbolic
    link for vendor/autoload.php pointing to debian/autoload.DEP-8.php.
  * Add new patch fixing wrong autoloader detection used by some tests
    - FrameworkBundle-SecurityBundle-Don-t-try-to-include-.patch
  * Drop temporary workaround patch (no longer needed)
    - Temporary-workaround.patch
  * Update patch to skip additional tests needing network
    - group-online-for-test-failing-without-network.patch
  * Add new patch to skip broken tests in the Process component
    - Skip-broken-tests-in-Process-component.patch
  * Provide missing meta.json for php-symfony-intl

 -- Daniel Beyer <dabe@deb.ymc.ch>  Fri, 02 Oct 2015 20:41:11 -0400